Vulnerability GHSA-j548-68g5-9j7x

Medium Risk
MEDIUM RISK
CVSS Score: 6.1
Score Range: 4.0–6.9
Medium severity vulnerabilities (CVSS 4.0–6.9). Important issues that meaningfully reduce security confidence.
4 months ago
June 30, 2026 at 12:31 PM UTC
Apache ActiveMQ, Apache ActiveMQ Web Console vulnerable to Cross-site Scripting
4.1.1 - 6.2.6
4.1.1 - 6.2.6

Summary

Apache ActiveMQ, Apache ActiveMQ Web Console vulnerable to Cross-site Scripting

Details

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console.

The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/JavaScript such that when an administrator browses the queue in the Web Console, the payload executes in their browser. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Web Console: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Timeline

Published
4 months ago
June 30, 2026 at 12:31 PM UTC
Fixed (6.2.7)
Unknown
Unknown
Fixed (5.19.8)
Unknown
Unknown
Fixed (6.2.7)
Unknown
Unknown
Last Modified
14 hours ago
November 05, 2026 at 05:56 PM UTC