Vulnerability GHSA-f892-4h9f-j7g9

High Risk
HIGH RISK
CVSS Score: 8.1
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
4 months ago
June 30, 2026 at 12:31 PM UTC
Apache ActiveMQ Improper Authorization vulnerability
4.1.1 - 5.19.7 and 6.0.0 - 6.2.6
4.1.1 - 5.19.7 and 6.0.0 - 6.2.6

Summary

Apache ActiveMQ Improper Authorization vulnerability

Details

Improper Authorization vulnerability in Apache ActiveMQ.

An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Timeline

Published
4 months ago
June 30, 2026 at 12:31 PM UTC
Fixed (5.19.8)
Unknown
Unknown
Fixed (6.2.7)
Unknown
Unknown
Last Modified
4 hours ago
November 04, 2026 at 04:25 PM UTC