Vulnerability GHSA-99qx-5qqr-4j95

High Risk
HIGH RISK
CVSS Score: 8.8
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
5 months ago
June 01, 2026 at 09:31 AM UTC
Apache ActiveMQ has an Incorrect Default Permissions vulnerability
4.1.1 - 5.19.6 and 6.0.0 - 6.2.5
4.1.1 - 5.19.6 and 6.0.0 - 6.2.5

Summary

Apache ActiveMQ has an Incorrect Default Permissions vulnerability

Details

Incorrect Default Permissions vulnerability in Apache ActiveMQ.

This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.

The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue.

Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Timeline

Published
5 months ago
June 01, 2026 at 09:31 AM UTC
Fixed (5.19.7)
Unknown
Unknown
Fixed (6.2.6)
Unknown
Unknown
Last Modified
3 months ago
July 09, 2026 at 09:26 PM UTC