Vulnerability GHSA-9qj4-v6r6-3wmx

High Risk
HIGH RISK
CVSS Score: 7.5
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
4 months ago
June 30, 2026 at 12:31 PM UTC
Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have a Denial of Service via Out of Memory vulnerability
5.19.7 and 6.2.6
5.19.7 and 6.2.6

Summary

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have a Denial of Service via Out of Memory vulnerability

Details

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.

Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7.

Users are recommended to upgrade to version 6.2.7, which fixes the issue.

Timeline

Published
4 months ago
June 30, 2026 at 12:31 PM UTC
Fixed (5.19.8)
Unknown
Unknown
Fixed (6.2.7)
Unknown
Unknown
Fixed (5.19.8)
Unknown
Unknown
Fixed (6.2.7)
Unknown
Unknown
Fixed (5.19.8)
Unknown
Unknown
Fixed (6.2.7)
Unknown
Unknown
Last Modified
4 hours ago
November 04, 2026 at 04:26 PM UTC