Vulnerability GHSA-mgp5-rv84-w37q

High Risk
HIGH RISK
CVSS Score: 7.5
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
8 months ago
February 17, 2026 at 09:31 PM UTC
Apache Tomcat has an Improper Input Validation vulnerability
9.0.83 - 9.0.113 and 10.1.0-M7 - 10.1.50 and 11.0.0-M1 - 11.0.15
9.0.83 - 9.0.113 and 10.1.0-M7 - 10.1.50 and 11.0.0-M1 - 11.0.15

Summary

Apache Tomcat has an Improper Input Validation vulnerability

Details

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.

When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.

This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.

The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.

Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.

Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

Related Vulnerabilities

Other vulnerabilities affecting the same packages

View all vulnerabilities for these packages

Timeline

Published
8 months ago
February 17, 2026 at 09:31 PM UTC
Fixed (11.0.18)
Unknown
Unknown
Fixed (10.1.52)
Unknown
Unknown
Fixed (9.0.115)
Unknown
Unknown
Fixed (11.0.18)
Unknown
Unknown
Fixed (10.1.52)
Unknown
Unknown
Fixed (9.0.115)
Unknown
Unknown
Fixed (11.0.18)
Unknown
Unknown
Fixed (10.1.52)
Unknown
Unknown
Fixed (9.0.115)
Unknown
Unknown
Last Modified
7 hours ago
November 04, 2026 at 03:30 AM UTC