Vulnerability GHSA-f525-44xv-f2qj

Critical
CRITICAL RISK
CVSS Score: 9.8
Score Range: 9.0–10.0
Critical severity vulnerabilities (CVSS 9.0–10.0). These represent the highest impact issues.
2 months ago
August 26, 2026 at 12:30 AM UTC
Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24

Summary

Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation

Details

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.

This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.

Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.

Related Vulnerabilities

Other vulnerabilities affecting the same packages

View all vulnerabilities for these packages

Timeline

Published
2 months ago
August 26, 2026 at 12:30 AM UTC
Fixed (11.0.25)
Unknown
Unknown
Fixed (10.1.59)
Unknown
Unknown
Fixed (9.0.121)
Unknown
Unknown
Fixed (11.0.25)
Unknown
Unknown
Fixed (10.1.59)
Unknown
Unknown
Fixed (9.0.121)
Unknown
Unknown
Last Modified
7 days ago
October 27, 2026 at 03:10 PM UTC