Vulnerability GHSA-5mp6-jrq3-r938

High Risk
HIGH RISK
CVSS Score: 7.5
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
5 months ago
May 12, 2026 at 06:30 PM UTC
Apache Tomcat: LockOutRealm treats user names as case-sensitive
7.0.0 - 9.0.117 and 10.1.0-M1 - 10.1.54 and 11.0.0-M1 - 11.0.21
7.0.0 - 9.0.117 and 10.1.0-M1 - 10.1.54 and 11.0.0-M1 - 11.0.21

Summary

Apache Tomcat: LockOutRealm treats user names as case-sensitive

Details

Improper Handling of Case Sensitivity vulnerability in LockOutRealm in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Related Vulnerabilities

Other vulnerabilities affecting the same packages

Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24 GHSA-f525-44xv-f2qj
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24 GHSA-f525-44xv-f2qj
Critical
2 months ago
Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability
7.0.0 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-gcx9-497g-6cp6
7.0.0 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-gcx9-497g-6cp6
View all vulnerabilities for these packages

Timeline

Published
5 months ago
May 12, 2026 at 06:30 PM UTC
Fixed (9.0.118)
Unknown
Unknown
Fixed (10.1.55)
Unknown
Unknown
Fixed (11.0.22)
Unknown
Unknown
Fixed (9.0.118)
Unknown
Unknown
Fixed (10.1.55)
Unknown
Unknown
Fixed (11.0.22)
Unknown
Unknown
Fixed (9.0.118)
Unknown
Unknown
Fixed (10.1.55)
Unknown
Unknown
Fixed (11.0.22)
Unknown
Unknown
Last Modified
1 month ago
September 11, 2026 at 08:25 AM UTC