Vulnerability GHSA-5v3h-fjv2-54fg

Medium Risk
MEDIUM RISK
CVSS Score: 6.5
Score Range: 4.0–6.9
Medium severity vulnerabilities (CVSS 4.0–6.9). Important issues that meaningfully reduce security confidence.
4 months ago
June 29, 2026 at 09:32 PM UTC
Apache Tomcat has an Improper Authorization vulnerability
7.0.0 - 7.0.109 and 8.5.0 - 9.0.118 and 10.1.0-M1 - 10.1.55 and 11.0.0-M1 - 11.0.22
7.0.0 - 7.0.109 and 8.5.0 - 9.0.118 and 10.1.0-M1 - 10.1.55 and 11.0.0-M1 - 11.0.22

Summary

Apache Tomcat has an Improper Authorization vulnerability

Details

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Related Vulnerabilities

Other vulnerabilities affecting the same packages

Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
7.0.30 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-9xv2-5v5q-p794
Critical
2 months ago
Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24 GHSA-f525-44xv-f2qj
9.0.115 - 9.0.120 and 10.1.53 - 10.1.57 and 11.0.20 - 11.0.24 GHSA-f525-44xv-f2qj
Critical
2 months ago
Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability
7.0.0 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-gcx9-497g-6cp6
7.0.0 - 7.0.109 and 8.5.0 - 9.0.120 and 10.1.0-M1 - 10.1.57 and 11.0.0-M1 - 11.0.24 GHSA-gcx9-497g-6cp6
View all vulnerabilities for these packages

Timeline

Published
4 months ago
June 29, 2026 at 09:32 PM UTC
Fixed (11.0.23)
Unknown
Unknown
Fixed (10.1.56)
Unknown
Unknown
Fixed (9.0.119)
Unknown
Unknown
Fixed (11.0.23)
Unknown
Unknown
Fixed (10.1.56)
Unknown
Unknown
Fixed (9.0.119)
Unknown
Unknown
Fixed (11.0.23)
Unknown
Unknown
Fixed (10.1.56)
Unknown
Unknown
Fixed (9.0.119)
Unknown
Unknown
Last Modified
4 hours ago
November 04, 2026 at 04:41 PM UTC