Vulnerability GO-2025-3422
Unknown
UNKNOWN RISK
Vulnerabilities without an assigned CVSS score. Severity is not determinable from available data.
1 year ago
January 28, 2025 at 03:01 PM UTC
imgproxy is vulnerable to SSRF against 0.0.0.0 in github.com/imgproxy/imgproxy
v1.1.1 - v2.2.11+incompatible
v1.1.1 - v2.2.11+incompatible
Summary
imgproxy is vulnerable to SSRF against 0.0.0.0 in github.com/imgproxy/imgproxy
Details
imgproxy is vulnerable to SSRF against 0.0.0.0 in github.com/imgproxy/imgproxy
Related Vulnerabilities
Other vulnerabilities affecting the same packages
Critical
6 hours ago
imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
Critical
6 hours ago
imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
Critical
6 hours ago
imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
>=4.0.0 <4.0.16 GHSA-hff9-5pqw-6w9f
High Risk
6 hours ago
imgproxy has out-of-bounds heap read/write in ICO loader BMP header reconstruction that allows unauthenticated remote worker crash
v3.3.0 - v3.31.4 GHSA-494m-4556-wf5p
v3.3.0 - v3.31.4 GHSA-494m-4556-wf5p
High Risk
6 hours ago
imgproxy has unbounded memory allocation in ICO loader that allows unauthenticated memory-exhaustion DoS via crafted data_size field
v3.3.0 - v3.31.4 GHSA-mmq5-xm89-9pfg
v3.3.0 - v3.31.4 GHSA-mmq5-xm89-9pfg
Impacted packages
Timeline
Published
1 year ago
January 28, 2025 at 03:01 PM UTC
Fixed (v3.27.2)
1 year ago
January 27, 2025 at 04:28 PM UTC
Last Modified
8 months ago
March 03, 2026 at 04:56 AM UTC