Vulnerability GHSA-xwhj-pqcg-8rcr

Medium Risk
MEDIUM RISK
CVSS Score: 6.0
Score Range: 4.0–6.9
Medium severity vulnerabilities (CVSS 4.0–6.9). Important issues that meaningfully reduce security confidence.
3 years ago
January 20, 2023 at 11:35 PM UTC
CakePHP vulnerable to Cross-site Scripting in some development error pages
3.4.0 - 3.4.13 and 3.5.0 - 3.5.16 and 3.6.0 - 3.6.3
3.4.0 - 3.4.13 and 3.5.0 - 3.5.16 and 3.6.0 - 3.6.3

Summary

CakePHP vulnerable to Cross-site Scripting in some development error pages

Details

CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only missing route and duplicate named route error pages.

Impacted packages

Timeline

Published
3 years ago
January 20, 2023 at 11:35 PM UTC
Fixed (3.6.4)
8 years ago
May 21, 2018 at 12:47 AM UTC
Fixed (3.4.14)
8 years ago
May 21, 2018 at 01:19 AM UTC
Fixed (3.5.17)
8 years ago
May 21, 2018 at 01:31 AM UTC
Last Modified
1 year ago
November 29, 2024 at 05:41 AM UTC