Vulnerability GHSA-x6wp-rfwh-hcx7
High Risk
HIGH RISK
CVSS Score: 7.5
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
8 years ago
July 24, 2018 at 07:55 PM UTC
Regular Expression Denial of Service in content
1.0.0 - 3.0.6
1.0.0 - 3.0.6
Summary
Regular Expression Denial of Service in content
Details
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
Related Vulnerabilities
Other vulnerabilities affecting the same packages
High Risk
6 hours ago
@hapi/content: quadratic-time parsing of Content-Disposition parameters allows denial of service
3.0.6 - 4.0.6 GHSA-8494-f6mr-cjpv
3.0.6 - 4.0.6 GHSA-8494-f6mr-cjpv
High Risk
6 years ago
Denial of Service in content
1.0.0 - 4.0.6 GHSA-5854-jvxx-2cg9
1.0.0 - 4.0.6 GHSA-5854-jvxx-2cg9
Impacted packages
Timeline
Published
8 years ago
July 24, 2018 at 07:55 PM UTC
Fixed (3.0.7)
8 years ago
March 01, 2018 at 09:06 AM UTC
Last Modified
2 years ago
November 08, 2023 at 03:59 AM UTC