Vulnerability GHSA-r7c9-c69m-rph8
Critical
CRITICAL RISK
CVSS Score: 9.8
Score Range: 9.0–10.0
Critical severity vulnerabilities (CVSS 9.0–10.0). These represent the highest impact issues.
4 years ago
March 26, 2022 at 12:19 AM UTC
Code Injection in PHPUnit
4.8.19 - 4.8.27 and 5.0.10 - 5.6.2
4.8.19 - 4.8.27 and 5.0.10 - 5.6.2
Summary
Code Injection in PHPUnit
Details
Util/PHP/eval-stdin.php in PHPUnit starting with 4.8.19 and before 4.8.28, as well as 5.x before 5.6.3, allows remote attackers to execute arbitrary PHP code via HTTP POST data beginning with a <?php substring, as demonstrated by an attack on a site with an exposed /vendor folder, i.e., external access to the /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php URI.
Related Vulnerabilities
Other vulnerabilities affecting the same packages
Medium Risk
6 hours ago
PHPUnit vulnerable to code execution by other local users via shared temporary directory in PHPT code coverage handling
13.4.0 - 13.4.3 GHSA-9vw2-f4vp-x7gf
13.4.0 - 13.4.3 GHSA-9vw2-f4vp-x7gf
High Risk
6 months ago
PHPUnit: Argument injection via newline in PHP INI values forwarded to child processes
12.5.21 and 13.1.5 GHSA-mh6w-vxff-9wqp
12.5.21 and 13.1.5 GHSA-mh6w-vxff-9wqp
High Risk
6 months ago
PHPUnit has Argument injection via newline in PHP INI values that are forwarded to child processes
12.5.21 and 13.1.5 GHSA-qrr6-mg7r-m243
12.5.21 and 13.1.5 GHSA-qrr6-mg7r-m243
High Risk
9 months ago
PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling
3.7.0 - 8.5.51 and 9.0.0 - 9.6.32 and 10.0.0 - 10.5.61 and 11.0.0 - 11.5.49 and 12.0.0 - 12.5.7 GHSA-vvj3-c3rp-c85p
3.7.0 - 8.5.51 and 9.0.0 - 9.6.32 and 10.0.0 - 10.5.61 and 11.0.0 - 11.5.49 and 12.0.0 - 12.5.7 GHSA-vvj3-c3rp-c85p
Impacted packages
Timeline
Published
4 years ago
March 26, 2022 at 12:19 AM UTC
Fixed (4.8.28)
9 years ago
November 14, 2016 at 06:25 AM UTC
Fixed (5.6.3)
9 years ago
November 14, 2016 at 06:39 AM UTC
Last Modified
1 year ago
October 22, 2025 at 07:24 PM UTC