Vulnerability GHSA-p2gc-fm5w-94jj
High Risk
HIGH RISK
CVSS Score: 7.5
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
3 months ago
August 05, 2026 at 09:31 AM UTC
Apache Qpid Proton-J: Unbounded type nesting can lead to pre-authentication stackoverflow
0.4 - 0.34.1
0.4 - 0.34.1
Summary
Apache Qpid Proton-J: Unbounded type nesting can lead to pre-authentication stackoverflow
Details
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid Proton-J: through 0.34.1.
Users are recommended to upgrade to version 0.35.0, which fixes the issue.
Related Vulnerabilities
Other vulnerabilities affecting the same packages
High Risk
7 years ago
Improper Certificate Validation in proton-j
0.4 - 0.29.0 GHSA-xvch-r4wf-h8w9
0.4 - 0.29.0 GHSA-xvch-r4wf-h8w9
Medium Risk
8 years ago
Moderate severity vulnerability that affects org.apache.qpid:proton-j
0.4 - 0.12.0 GHSA-f5cf-f7px-xpmh
0.4 - 0.12.0 GHSA-f5cf-f7px-xpmh
Impacted packages
Timeline
Published
3 months ago
August 05, 2026 at 09:31 AM UTC
Fixed (0.35.0)
Unknown
Unknown
Last Modified
12 hours ago
November 03, 2026 at 09:45 PM UTC