Vulnerability GHSA-9v8h-qqgm-4m35

Critical
CRITICAL RISK
CVSS Score: 9.5
Score Range: 9.0–10.0
Critical severity vulnerabilities (CVSS 9.0–10.0). These represent the highest impact issues.
8 days ago
October 22, 2026 at 03:32 PM UTC
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
1.0.4 - 1.2.0
1.0.4 - 1.2.0

Summary

Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

Details

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Impacted packages

Timeline

Published
8 days ago
October 22, 2026 at 03:32 PM UTC
Fixed (1.2.1)
8 days ago
October 22, 2026 at 01:58 PM UTC
Fixed (1.2.1.0)
8 days ago
October 22, 2026 at 04:19 PM UTC
Last Modified
1 day ago
October 29, 2026 at 02:45 PM UTC