Vulnerability GHSA-3wqh-h42r-x8fq

High Risk
HIGH RISK
CVSS Score: 8.0
Score Range: 7.0–8.9
High severity vulnerabilities (CVSS 7.0–8.9). Serious vulnerabilities that should be prioritized soon after critical fixes.
6 years ago
September 03, 2020 at 03:46 PM UTC
Denial of Service in @hapi/content
4.1.0 - 5.0.1
4.1.0 - 5.0.1

Summary

Denial of Service in @hapi/content

Details

Versions of @hapi/content prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

Impacted packages

Timeline

Published
6 years ago
September 03, 2020 at 03:46 PM UTC
Fixed (5.0.2)
6 years ago
February 13, 2020 at 08:07 AM UTC
Last Modified
1 year ago
September 25, 2025 at 10:29 PM UTC